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序文  

 

これは、2010 年に KNIME Press のために書いた、KNIME Analytics Platform の使い方についての最初の本です。この本の 10 周年が近づいて

きましたので、私たち（KNIME Press チームと私）はこの本に新しい序文が必要ではないかと考えました。本書は誕生以来、年 2 回、

KNIME Analytics Platform の新しいリリースのたびに更新されている為、実際には全体的な更新は必要ありません。 

KNIME Beginner's Luck は、KNIME Press の他の電子書籍と同様に、常に最新バージョンの KNIME に合わせて更新される電子書籍です。この

ように変化し続ける電子書籍だからこそ、ほとんど印刷されていません。印刷されたページを更新するのは、pdf ファイルを更新するよ

りも大変です。 

本書は最初の本ですので、基本的なことを書いています：KNIME Analytics Platform の基本はもちろんのこと、データサイエンスプロジェ

クトの基本についても書いています。本書では、KNIME Analytics Platform で利用できる最も重要なアクセス機能、データ変換操作、そし

て機械学習ノードについても解説しています。  多くのサンプルワークフロー、演習、スクリーンショットなどで補足されており、ソフ

トウェアの基本的な機能にすぐに慣れることができます。より高度なトピックをお探しの方は、ここでは紹介することができません。 

高度な機械学習アルゴリズムやフロー変数、ループについてもっと詳しく知りたい方は、本書の続編”KNIME Advanced Luck“を確認してみ

てください。テキスト処理についてもっと学びたいなら、”From Words To Wisdom“をご覧ください。マニュアルや説明書を読むことを大

事とする考えの人は、”Practicing Data Science”の中の様々なアプリケーション分野の事例の解答を読むことから始めてみてはいかがでし

ょうか。あなたの仕事が、異なるデータやデータ型の統合と融合に関するものであれば、”Will they blend?“コレクションをお勧めします。

SAS、Excel、Alteryx から移行する場合は、KNIME Press のページで、より便利な小冊子を入手することができます。  

これはすべて、KNIME Press チームと私が、KNIME ソフトウェアとデータサイエンスのコンセプトをより深く、より生産性の高いものに

するための学習教材、書籍、チュートリアルを皆様に提供するために努力してきたということです。  

 

Rosaria Silipo (多数の KNIME Press 書籍, PhD の著者)  

https://www.knime.com/knimepress/knime-advanced-luck
https://www.knime.com/knimepress/from-words-to-wisdom
https://www.knime.com/knimepress/download-will-they-blend
https://www.knime.com/knimepress/download-will-they-blend
https://www.knime.com/knimepress/download-will-they-blend
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まず、私の数多くの質問に辛抱強く対応してくれた KNIME チームの皆さんに感謝したいと思います。  

KNIME チームの中でも特に、KNIME の最も効率のよい技法と互換性のない部分を見つけるために本書をレビューしてくれた Peter Ohl 氏に

感謝したいと思います。  

また、私が想像した中で最も美しく、明確で、芸術的なスクリーンショットを提供してくれた Casiana Rimbu 氏、そして、この本を書く
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第 1 章 はじめに  

 

1.1. 本書の目的と構成  
 

私たちはデータの時代に生きています。私たちが購入した商品はすべて正確に記録され、金銭取引はすべて慎重に登録されています。ウ

ェブのクリックはすべてウェブクリックアーカイブに記録されます。今日では、あらゆるものに RFID チップが搭載され、データを記録

することができます。私たちはこれまでにないほどのデータを手に入れることができます。これらすべてのデータを使って何ができるの

でしょうか？私たちはそれを使って何か意味のあることができるのでしょうか？何か有用で有益なことを学ぶために、それを使用するこ

とはできるでしょうか？私たちに必要なのは、データをより深く切り込み、様々な視点からデータを見て、その基礎となる構造を表現で

きるようにするツール、サージカルナイフなのです。 

このように膨大な量のデータがすでに入手可能で、分析されるのを待っていると仮定しましょう。専門家がビジネスインテリジェンス

（BI）やデータサイエンス（DS）の世界に入るためには、どのような選択肢があるのでしょうか？利用可能な選択肢はもちろん複数あり、

急速に成長しています。私たちの専門家が過度の予算を管理できない場合は、オープンソース・ソフトウェアの世界に目を向けることが

できます。しかし、オープンソース・ソフトウェアは、単にお金に頼った選択ではありません。多くの場合、それはリソースの共有と管

理のためのソフトウェア哲学を表しており、多くの専門家がそれを支持しています。  

オープンソース・ソフトウェアの世界では、いくつかのデータサイエンスと BI ツールを見つけることができます。KNIME Analytics 

Platform は初心者の専門家にとって簡単な選択です。特定のスクリプトを学ぶ必要がなく、分析手順を実装して文書化するためのグラフ

ィカル・ユーザー・インターフェース（GUI）を提供しています。さらに、これは二次的な利点ではありませんが、KNIME Analytics 

Platform は、他の多くの BI やデータサイエンスツールを拡張できる統合プラットフォームとして機能します。これにより、KNIME 

Analytics Platform を使ってデータを分析し、別の BI ツールを使って同じ処理済みデータにダッシュボードを構築することが可能なだけで

なく、簡単にできます。 

KNIME Analytics Platform は非常にシンプルで直感的に使用できますが、初心者の方は、ノード、カテゴリ、設定などすべての機能につい

てのオリエンテーションを早めることで利益を得ることができます。本書は、どんな初心者でも学習プロセスを進めるのに役立つことを

目的としている為、初心者の幸運を表しています。本書は KNIME ソフトウェア全体の網羅的なガイドではありません。オープンソース
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ではない KNIME サーバーの下での実装や、上級者向けと思われるトピックはカバーしていません。例えばフロー変数やデータベース SQL

クエリの実装については、続編の”KNIME Advanced Luck“で説明されています。 

本書は 6 つの章に分かれています。第 1 章では、KNIME Analytics Platform の基本的な概念を説明し、第 2 章では読者を最初の KNIME アプ

リケーションの実装に導きます。第 3 章からは、データサイエンスの概念をより深く掘り下げていきます。第 3 章では、ノードと処理フ

ローの観点から、基本的なデータの探索と可視化を行う方法を説明しています。第 4 章はデータモデリングに特化しています。それは、

機械学習、ナイーブベイズ、決定木、人工ニューラルネットワークへのいくつかの実証的なアプローチを説明しています。最後に、第 5

章と第 6 章はレポートに特化しています。通常、データの可視化、または後のフェーズでのデータモデリングに基づく調査の結果は、同

僚、経営陣、取締役、顧客、または外部の作業員に何らかの形で示されなければなりません。このように、レポートは、データ分析プロ

セスの最後にある非常に重要なフェーズです。第 5 章では、レポートにエクスポートするためのデータを準備する方法を示し、第 6 章で

はレポート自体を構築する方法を示しています。 

各章では、ETL または機械学習(ML)プロセスの段階的に説明しています。各ステップは詳細に説明されており、現在のノードの代替につ

いての説明を提供しています。各章の最後には、これまでに学んだことをテストし、完璧にするためのいくつかの練習問題が読者に提案

されています。 

本書の例題と演習は KNIME 4.1 を使って実装されています。見た目に若干の違いがあるかもしれませんが、それ以降の KNIME バージョン

でも動作するはずです。  

1.2. KNIME community 
オープンソースのソフトウェアである KNIME Analytics Platform は、世界中の KNIME ユーザーの多くのフォーラムやグループから恩恵を

受けています。これは、アドバイス、ヒント、学習教材のための良いセーフティネットです。ここでは、KNIME ユーザーに最も人気のあ

るサイトやグループをご紹介します。 

便利な Web ページ 
 

http://www.knime.org  KNIME の web サイトのルートページ。 
 

https://www.knime.com/knime-software/knime-server
https://www.knime.com/knime-software/knime-server
https://www.knime.com/knimepress/knime-advanced-luck
https://en.wikipedia.org/wiki/Extract,_transform,_load
http://www.knime.org/
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SAMPLE 

 

コース、イベント、動画 
 

KNIME Analytics Platform のコース 
  

KNIME は、KNIME ソフトウェアのオンサイトおよびオンラインコースを定期的に提供して

います。次回の開催日を確認し、登録するには、KNIME のイベントページ（KNIME は、

KNIME ソフトウェアのオンサイトおよびオンラインコースを定期的に提供しています。次

回の開催日を確認し、登録するには、KNIME のイベントページ

（https://www.knime.com/learning/events）にアクセスしてください。 
 

KNIME ウェビナー 2013 年 5 月以降、化学ノード、テキストマイニング、他の分析ツールとの統合、自動化さ

れた機械学習、ベストプラクティスなど、特定のトピックに関するウェビナーも多数開催

されています。次回のウェビナーについては、KNIME イベントのWeb ページ

（https://www.knime.com/learning/events）をご覧ください。 

KNIME Meetups と KNIME Summits KNIME Meetup と KNIME Summits は世界中で定期的に開催されています。これらは、KNIME

ソフトウェアについて学び、新しいデータサイエンスプロジェクトについてインスピレー

ションを得たり、KNIME Community の他の人々と知り合う良い機会です。

(https://www.knime.com/learning/events と https://www.knime.com/summits) 
 

https://www.knime.com/knime-software  KNIME の全製品の概要を最初に確認する場所です。オープンソースの KNIME Analytics 

Platform はこちらからダウンロードできます。 

https://www.knime.com/knime-
introductory-course  

これは、特定の KNIME の機能について詳しく学ぶことが出来る KNIME e ラーニングコース

のルートページです。データアクセス、データ探索から機械学習、制御構造まで、データ

サイエンスサイクル全体を説明しています。 

 
https://hub.knime.com/   

ワークフロー、例、拡張機能、コンポーネントのテンプレート、ノードなどの KNIME の資

料の公開リポジトリです。実用的な例から始めたい場合は、ここに入力した検索用語に応

じて多くの例を見つけることができます。 

 
https://forum.knime.com/  

私が特に便利だと思うのは、 KNIME Forum です。ここでは、KNIME Analytics Platform の使

用方法、または新しいノードで拡張する方法について質問することができます。KNIME  

community の誰かが常に迅速に回答してくれます。 
 

https://www.knime.com/learning/events
https://www.knime.com/learning/events
https://www.knime.com/learning/events
https://www.knime.com/summits
https://www.knime.com/knime-software
https://www.knime.com/knime-introductory-course
https://www.knime.com/knime-introductory-course
https://hub.knime.com/
https://forum.knime.com/
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YouTube の KNIME TV チャンネル KNIME は YouTube に KNIMETV という独自のビデオチャンネルを持っています。そこでは、

多くの異なるトピックについての詳細や、KNIME の新リリースの新機能についての最新情

報を得るためのビデオが用意されています。 (http://www.youtube.com/user/KNIMETV)  
 

 

書籍 
 

KNIME Analytics Platform 上級者向け： 

Rosaria Silipo 氏 , Jeanette Prinz 氏 , “KNIME Advanced Luck” 
(https://www.knime.com/knimepress/knime-advanced-luck)  
 

レポートスイート KNIME レポートスイートは、レポート作成のためのもう一つのオープンソースツールであ

る BIRT をベースにしています。ここでは、BIRT の使用方法についての基本的なガイドをご

紹介します。 

D. Peh 氏, N. Hague 氏, J. Tatchell 氏, “BIRT. A field Guide to Reporting”, Addison-Wesley, 2008 

データサイエンスと KNIME データサイエンス、データマイニング、データアナリティクスの概要については、こちら

をご確認ください。Berthold  M.R., Borgelt  C., Höppner F., Klawonn F., “Guide to intelligent data 
analysis”, Springer 2010. 

 

KNIME Hub 

KNIME ノードに関する情報や、次のプロジェクトのためのサンプルワークフローを見つけることができる場所があります：KNIME Hub 
(https://hub.knime.com/). 

KNIME Hub は、KNIME Analytics Platform で再使用、再利用、およびアセンブルするためのアプリケーション、コンポーネント、およびノ

ードのリポジトリです。あるいは、ホームページに記載している通りです：KNIME Hub は”KNIME ワークフローとノードを見つけてコラ

ボレーションする場所”です。ここでは、データサイエンスの質問に対する解決策を見つけることができます。  

KNIME Hub に初めてアクセスすると、図 1.1 のページが表示されます。このページには、スタートガイドのドキュメント、KNIME forum、

KNIME blog へのリンクがいくつか含まれています。最も重要なことは、上部にある検索ボックスから、KNIME ユーザーがアップロードし

たアプリケーション、ノード、コンポーネントを検索することができ、KNIME コミュニティの共有の場となっています。 

http://www.youtube.com/user/KNIMETV
https://hub.knime.com/
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SAMPLE 
1.1. KNIME Hub のホームページ https://hub.knime.com/ 

 

検索ボックスに”Customer Intelligence”と入力すると、カスタマーインテリジェンスに関連するノードとワークフローの一覧が

表示されます。ここでは、トップメニューの”Workflows”だけを選択してみましょう。 図 1.2 の下には、KNIME community のユ

ーザーがアップロードした、カスタマーインテリジェンスのいくつかの側面を実装し、適切にタグ付けされたアプリケーシ

ョン（ワークフロー）の一覧が表示されています。実際に、KNIME Hub にはあなた自身が開発したアプリケーションをアップ

ロードすることができます。必要なのは KNIME forum のアカウントだけです。 

1.2. カスタマーインテリジェンスに関連し（タグ付けされた）、 KNIME Hub で利用可能なアプリケーション（ワークフロー）の一覧 

https://hub.knime.com/
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SAMPLE 

 

一覧内のアプリケーションをクリックすると、そのアプリケーションの Web ページが開き、実装の説明が表示されます(図

1.3)。右側の”Open workflow”ボタンをクリックすると、現在の KNIME Analytics Platform のインストレーション内でアプリケー

ションを開くことができます。 

1.3.KNIME Hub の”Customer Segmentation”という名前のアプリケーション専用ページ 
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SAMPLE 

 
 

 

 

1.3. KNIME Analytics Platform のダウンロードとインストール  
 

KNIME の商品は 2 種類あります。  

- オープンソースの KNIME Analytics Platform は、GPL バージョンの 3 ライセンスの下、https://www.knime.com/knime-software から

無料でダウンロードできます。 

https://www.knime.com/knime-software/knime-analytics-platform


 

23 

 

 

SAMPLE 
- KNIME サーバーについては https://www.knime.com/knime-software/knime-server を参照してください。  

分析的に言えば、2 つの製品の機能性は同じです。KNIME サーバーには、チームコラボレーション、エンタープライズワークフローのデ

プロイメントと管理、データウェアハウス、統合、データサイエンスラボのためのスケーラビリティなど、多数の IT 機能が含まれてい

ます。しかし、本書では、KNIME Analytics Platform（オープンソース）を使用して作業します。KNIME Analytics Platform で作業を始めるに

は、まず、ダウンロードする必要があります。 

KNIME Analytics Platform のダウンロード  

- www.knime.org にアクセスしてください。 

- メインページの右上にある”Download”をクリック

してください。  

- 自信の情報を少し入力してから（感謝します）、

ステップ 2 の “Download KNIME”に進みます。  

- お使いの環境（Windows/Mac/Linux、32 ビット/64

ビット、Windows 用インストーラーの有無に関わ

らず）に合わせてバージョンを選択してくださ

い。 

- 規約に同意してください。 

- ダウンロードを開始します。最終的には、zip 形式

（*.zip）、自己解凍型アーカイブファイル

（*.exe）、またはインストーラーアプリケーショ

ンのいずれかになります。 

- .zip や.exe ファイルの場合は、保存先のフォルダ

に解凍するだけです。インストーラのバージョン

を選択した場合は、それを実行して、インストー

ラの指示に従ってください。 

 

1.4.KNIME のウェブページ 

 

 

file:///C:/Users/tjg06645/Desktop/KNIMEサーバー
file:///C:/Users/tjg06645/Desktop/KNIMEサーバー
http://www.knime.org/
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SAMPLE 
1.4. ワークスペース  

KNIME Analytics Platform を起動するには、KNIME をインストールしたフォルダを開き、knime.exe（Linux/Mac マシンの場合は knime）を実

行します。インストーラを使用して KNIME をインストールした場合は、デスクトップまたは Windows のメインメニューでアイコンをク

リックします。 

初めて KNIME Analytics Platform をご利用になる場合は、ご自身の使用統計情報を KNIME と共有するかどうかを尋ねられます。これらの統

計情報は、KNIME Analytics Platform のワークベンチ内で提供されるベストプラクティスの推奨エンジンであるワークフローコーチに使用

されます。個人情報が KNIME に届くことはありませんし、匿名の統計情報が誰かと共有されることもありません。 

スプラッシュ画面の後、”ワークスペースランチャー”画面では、ワークスペースのパスを入力する必要があります。  

ワークスペースランチャー  

ワークスペースは、開発中および開発中のすべての

環境設定とアプリケーション（ワークフロー）が、

次の KNIME セッションのために保存されるフォルダ

です。  

ワークスペースフォルダは、ハードディスク上のど

こにでも配置できます。  

デフォルトでは、ワークスペースのフォルダ

は”...\KNIME-workspace”となっています。しかし、

KNIME ワーキングセッションを開始する前に”ワーク

スペースランチャー”画面で提案されたパスを変更す

ることで、簡単に変更することができます。 

 

1.5.”ワークスペースランチャー”画面 
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SAMPLE 
KNIME Analytics Platform を開いたら、KNIME ワークベンチ内から、トップメニューの”File”を選択して”Switch Workspace”を選択すること

で、別のワークスペースフォルダに切り替えることができます。新しいワークスペースを選択すると、KNIME Analytics Platform が再起動

し、新しく選択したワークスペースのワークフローの一覧が表示されます。ワークスペースフォルダが存在しない場合は、自動的に作成

されることに注意してください。 

例えば、多くのユーザがいる場合は、それぞれのユーザごとに異なるワークスペースを使用することができます。そうすることで、ワー

クスペースが整理整頓され、誤って情報が混同するのを防ぐことが出来ます。今回は”KNIME_4.x.y\book_workspace”というワークスペー

スを使用しました。 

1.5. KNIME ワークフロー  

KNIME Analytics Platform はスクリプトではなく、グラフィカルなワークフローで動作します。  

ノードと呼ばれる小さなアイコンは、与えられたタスクを実装して実行するための専用のものです。一連のノードは、目的の結果に到達

するために、データを処理するためのワークフローを作成します。 
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SAMPLE 

 

 

 

注意.ワークフローはデータ分析のシーケンスであり、従来のプログラミング言語では、一連の命令と関数の呼び出しによって実装され

ます。KNIME Analytics Platform は、それをグラフィカルに実装しています。このグラフィカルな表現は、より直感的に使用でき、分析プ

ロセスの概要を把握することができ、ドキュメントの作成にも役立ちます。 

 

ワークフローとは  
 

ワークフローとは、分析の流れのことで、ある結果を得るために必要な一連の

分析手順のことを指します。これは、分析プロセスのパイプラインであり、次

のようなものです： 

ステップ 1.  データを読み込む 

ステップ 2.  データのクリーン化 

ステップ 3.  データをフィルタリングする 

ステップ 4.  モデルを訓練する 
 

KNIME Analytics Platform は、ワークフローをグラフィカルに実装しています。デ

ータ分析の各ステップは、ノードと呼ばれる小さなボックスを通して実装さ

れ、実行されます。一連のノードがワークフローを作成します。  

KNIME ホワイトペーパー[1]では、ワークフローは以下のように定義されていま

す：”KNIME におけるワークフローは、ノードを結ぶグラフ、正式には、有向非巡回グ

ラフ(DAG)である。(http://www.kdd2006.com/docs/KDD06_Demo_13_Knime.pdf)   

以下は、KNIME のワークフローの例です。 

- ファイルからデータを読み込むノード  

- 一部のデータ列を除外するためのノード  

- いくつかのデータ行をフィルタリングするため

のノード  

- 処理されたデータをファイルに書き込むノード 

1.6.KNIME ワークフローの例 
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SAMPLE 
 

1.6. .knwf および .knar ファイル拡張子  

KNIME ワークフローは、.knwf または.knar ファイルでパッケージ化してエクスポートすることができます。.knwf ファイルには 1 つのワ

ークフローのみが含まれ、.knar ファイルにはワークフローのグループが含まれます。このような拡張子は、KNIME Analytics Platform に関

連付けられています。ダブルクリックすると、KNIME Analytics Platform プラットフォーム内のワークフローが開きます。 

ノードとは  
 

ノードは、ワークフローの単一の処理単位です。  

ノードはデータセットを入力として受け取り、それを処理し、出力

ポートで利用できるようにします。ノードの”処理”動作は、 Neural 

Network Learner ノードのようなモデリングから、入力データ行列の

転置などのデータ操作、散布図のようなグラフィカルなツールか

ら、読み書き操作に至るまで、多岐にわたります。 

KNIME の各ノードは 4 つの状態を持っています： 

- 非アクティブでまだ設定されていない  → 赤色 

- 設定されているがまだ実行されていない → 黄色 

- 正常に実行された           → 緑色 

- 実行してエラー            → 赤色でバツ印 

- 他のノードを含むノードは、メタノードまたはコンポーネン

トと呼ばれます。 

以下では、同じノード（File Reader ノード）を 4 つの状態ごとに例示し

ています。 

 

1.7.状態の異なるファイルリーダーノード 
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SAMPLE 
1.8.KNIME Analytics Platform には、.KNWF ファイルと.KNAR ファイルが関連付けられています。ダブルクリックすると、ワークフローが開きます。 

 

1.7. KNIME ワークベンチ  

ワークスペースのパスを受け入れると、KNIME ワークベンチは”Welcome to KNIME”ページが開きます。このページには、例えば KNIME 

Hub、基本的なドキュメント、現在のコースやイベント、利用可能なアップデートなど、開始するためのリンクがいくつか用意されてい

ます。”KNIME Workbench”はトップメニュー、ツールバー、いくつかのパネルで構成されています。パネルは閉じたり、開いたり、移動

したりすることができます。 
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SAMPLE 
1.9.KNIME のワークベンチ 

 

KNIME ワークベンチ  

トップメニュー：File, Edit, View, Node, Help 
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SAMPLE 
ツールバー：新規作成、保存（名前を付けて保存、すべて保存）、元に戻す/やり直し、レポートを開く（レポートがインストールされてい

る場合）、ズーム（％単位）、選択したノードを縦/横に整列、自動レイアウト、設定、実行オプション、実行オプションのキャンセル、リセ

ット、ノード名と説明の編集、ノードの最初の出力ポートのテーブルを開く、ノードの最初のビューを開く、”Add Meta node”ウィザードを開

く、ノード名に ID を追加、すべてのノード名を非表示、ループ実行オプション、Workflow Editor の設定変更、コンポーネントのレイアウト編

集、ジョブマネージャの設定。 

KNIME Explorer 

このパネルは、選択したワークス

ペース（LOCAL）、EXAMPLES サ

ーバー、My-KNIME-Hub（KNIME 

Hub 上の自分のスペース）、また

は他の接続された KNIME サーバ

ーで利用可能なワークフロープロ

ジェクトの一覧が表示されます。 

Workflow Editor 

中央のエリアは”Workflow Editor”そのもので構成されています。  

“Node Repository”パネルからノードを選択し、”Workflow Editor”パネルにド

ラッグ＆ドロップすることができます。  

ノードは、あるノードの出力ポートをクリックして、次のノードの入力ポ

ートまたは、次のノードにマウスを放すことで、ノードを接続することが

できます。 

Workflow & Node Descript
ion 

ノードまたはワークフロー
が選択されている場合、こ

のパネルには、ノードの機

能やワークフローのメタ情

報の概要が表示されます。  

Workflow Coach 

これはノード推奨エンジンです。

現在選択されているノードに続い

て、接続される可能性の高いノー

ドの一覧を提供します。 

Seach on KNIME Hub 

KNIME Hub で資料を検索す

るのに役立ちます。 
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Node Repository   

このパネルには、KNIME のインス

トールで利用可能なすべてのノー

ドが含まれています。これはレポ

ートやWebデザイナーソフトウェ

アで作業するときのツールパレッ

トに似ています。ここではグラフ

ィカルツールを使用しますが、

KNIME ではデータ分析ツールを使

用します。 

Outline 

“Outline”パネルは、”Workflow Editor”の内容

の概要を紹介しています。ワークフローの

規模が小さい場合は、”Outline”パネルはあ

まり必要がないかもしれません。しかし、

ワークフローが大規模になると、スクロー

ルをしないとすべてのノードが”Workflow 

Editor”に表示されなくなる場合がありま

す。このような時、”Outline”パネルは、新

しく作成されたノードを見つけるのに役立

ちます。 

Console 

“Console”パネルには、エラーメッセージと警告メッセージ

がユーザーに表示されます。 

このパネルには、ログファイルの場所も表示されます。こ

れは、コンソールにすべてのメッセージが表示されない場

合に役立ちます。 

ツールバーには、この KNIME インスタンスに関連付けられ

たログファイルを表示するボタンもあります。 
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トップメニュー  

File Edit View 

 

 

 

 

 

File には、”新規作成”や”保存”などのファイルコ

マンドに加えて、KNIME 特有のコマンドが含ま

れています。 

- Import/Export KNIME workflow… 

- Export to SVG 

- Switch Workspace 

- Preferences with Export/Import Preferences 

 

Edit には編集コマンドが含まれ

ています。 

Undo と Redo は、最後に実行さ

れたアクションを指します。 

 

View には、KNIME ワークベンチで開くことができるすべて

のパネルの一覧が含まれています。 

閉じたパネルは、ここで再度開くことができます。 

また、パネルの配置が滅茶苦茶になった場合、 ”Reset 

Perspective “というオプションで、初めて作業台を起動した
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- Install KNIME Extensions  

- Update KNIME 

Cut, Copy, Paste, Delete は、ワー

クフロー内の選択されたノード

を参照します。  

Select All ：”Workflow Editor”で

ワークフローのすべてのノード

を選択します。 

時と同じ元のパネルレイアウトを再現することができま

す。 

オプション”Other”を選択すると、ワークベンチをカスタマ

イズするのに便利な追加のビューが開きます。 

Node Help 

 

 

Node とは、ノード上で実行可能なすべての操作を指します。ノードは、次の

ようなことができます： 

- 設定 

- 実行 

Help コンテンツでは、ワークベンチ、BIRT、KNIME に関する一

般的なヘルプを提供しています。 
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SAMPLE 
- キャンセル（実行中に停止） 

- リセット(最後の”実行”操作の結果をリセット) 

- 名前と説明を編集 

- そのビューを表示するように設定（もしあれば） 

オプションは、可能な場合にのみ有効です。例えば、既に正常に実行されたノ

ードは、最初にリセットされるか、構成が変更されない限り、再実行すること

はできません。その場合、”Cancel”と”Execute”オプションは非アクティブにな

ります。 

オプションの”Open Meta Node Wizard”を選択すると、Workflow Editor で新しい

メタノードを作成するためのウィザードが起動します。 

“Search”は、”Node Description”パネルの右側にパネルが開き、特

定のヘルプトピックまたはノードを検索できます。 

“Welcome Page”は、(再)ウェルカムページを開きます。 

“Install New Software”は、KNIME アップデートサイトから KNIME 

Extensions をインストールすることができます。 

“Show Active Keybindings” は、Workflow Editor のすべてのキーボ

ードコマンドをまとめて表示します。  

“Cheat Sheets”は、レポートツール、cvs、プラグインなど、特定

のトピックに関するチュートリアルを提供します。  
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それでは、トップメニューの中で最も使用頻度の高い項目を見ていきまし

ょう。 

“File” -> “Import KNIME workflow”は、ワークフローを現在のワークスペー

スに読み込んでコピーします。  

オプションの”Select root directory”は、ワークフローをフォルダから現在の

ワークスペース（LOCAL）に直接コピーします。  

オプションの”Select archive file”では、.knwf または.knar ファイルから現在

のワークスペース(LOCAL)にワークフローを読み込みます。 

 

“File” -> “Export KNIME workflow”は、選択したワークフローを.knwf に、ま

たは選択した多数のワークフローを.knarファイルにエクスポートします。  

オプションの”Reset Workflow(s) before export” は、各ノードで生成されたデ

ータを使用せずに、完全にリセットされたワークフローをエクスポートし

ます。これにより、かなり小さいエクスポートファイルが生成されます。 

ワークフローをあるフォルダから別のフォルダにコピーするだけでは、内

部の KNIME アップデートに関連した多くの問題が発生する可能性がありま

す。ワークフローのコピーには”Import KNIME workflow”オプションを使用

するか、ダブルクリックした方が安全です。  

“File” -> “Install KNIME Extensions”と”Help” -> “Install New Software”は、どち

らも KNIME アップデートサイトから KNIME の拡張機能をインストールす

るためのダイアログ画面にリンクしています（次項参照）。 

1.10.ワークフローをインポートするための”Import”画面

 

“File” -> “Switch Workspace”は、現在のワークスペースを新しいワークスペースに変更します。 

“File” -> “Preferences”では、すべての KNIME 設定をカスタマイズできる画面が表示されます。これらの設定は”KNIME”の項目の下

にあります。そちらを確認してみましょう。 
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SAMPLE 
• Chemistry には、ケミストリーパッケージの KNIME Renderers に関連した設定があります。 

• Databases には、KNIME 内で利用できない特定のデータベースドライバの場所を指定します。最も一般的で最新のデータ

ベースドライバはデータベースノードのドライバメニューで利用可能です。しかし、特定のドライバファイルが必要な場

合は、ここでパスを設定することができます。 
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SAMPLE 
 

1.11. “Preferences”画面 

 

• KNIME Explorer には、KNIME サーバーを経由した共有リポ

ジトリの一覧が含まれています。  

• KNIME GUIでは、KNIMEワークベンチのオプションやレイ

アウトをいくつかの設定でカスタマイズすることができ

ます。 

• Master Key には、database connection ノードのような暗号

化オプションを持つノードで使用するマスターキーが含

まれています。KNIME 2.3 以降、データベースのパスワー

ドは”Credentials”ワークフロー変数を介して渡され、マス

ターキーの設定は非推奨となりました。互換性を保つた

めに、”Preferences”メニューには引き続き表示されま

す。 

• Meta Info Preferences では、ノードとワークフローのメタ

情報のテンプレートをアップロードすることができま

す。 

• ここでは、H2O、R、レポートデザイナー、Perl、Perl、

Open Street Map などの外部パッケージの設定も確認でき

ます（インストールされている場合）。特に、外部スク

リプトについては、このページで参照スクリプトのイン

ストール先のパスを設定するオプションがあります。  

• 最後に、Workflow Coach には、ノード推奨エンジンに使

用するデータセットが含まれています。 

“File”メニューの Export Preferences と Import Preferences は、それぞれ”Preferences”の設定を*.epf ファイルにエクスポートした

り、*.epfファイルをインポートします。これら 2つのコマンドは、例えば KNIME の新しいバージョンがインストールされ、古い

環境設定をインポートしたい場合などに便利です。 
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SAMPLE 
ツールバー  

ツールバーも KNIME ワークベンチの重要な部分です。  

左から、新規ワークフローの作成、選択したワークフローの保存、選択したワークフローを別の場所に保存、開いているワーク

フローをすべて保存、元に戻す/やり直し、レポート環境への切り替え、ズーム（％単位）、選択したノードを垂直方向に揃え

る、選択したノードを水平方向に揃える、自動レイアウト、選択したノードの設定、選択したノードの実行、すべての実行可能

なノードの実行、選択したノードの実行、選択したノードを実行し、最初のデータビューを開く、選択した実行中のノードのキ

ャンセル、実行中のすべてのノードのキャンセル、選択したノードのリセット、選択したノードの説明の編集、選択したノード

の最初のデータビューを開く、選択したノードのビューを開く、メタノードの追加ウィザードを開く、ノード名に ID を追加す

る、ノード名を非表示にする、1 つのループステップを行う、ループ実行を一時停止する、ループ実行を再開する、Workflow 

Editor の設定を変更する、コンポーネントのレイアウト編集、選択したすべてのノードのジョブマネージャの設定。これらのオ

プションをすべて、本書のコースに沿って見ていきます。 

先ず、”Auto Layout”ボタンについて説明したいと思います。Auto Layout ボタンは、ワークフロー内のノードの位置を自動的に調

整して、順序付けられた、探索しやすいワークフローを作成します。この自動レイアウト操作は、例えば長時間の開発セッショ

ンの後、ワークフローの概要が分かりづらくなった場合などに特に有効です。  

1.12.ツールバーの”Auto Layout”ボタン 

 

キーボードが好きな方には、ほとんどの KNIME コマンドはホットキーを使って実行することができます。すべてのホットキー

は、対応するコマンドの横にある KNIME メニュー、またはトップメニューのツールバーにあるアイコンのツールチップメッセー

ジに記載されています。ここでは最もよく使用されるホットキーを紹介します。 

ホットキー  
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SAMPLE 
ノード設定 

• F6 は、選択したノードの設定画面を開きます。 

ノード実行 

• F7 は、選択された設定済みノードを実行します。 

• Shift + F7 は、設定されたすべてのノードを実行しま

す。 

• Shift + F10 は、すべての設定されたノードを実行し、

すべてのビューを開きます。 

ノードの停止 

• F9 は、選択された実行中のノードをキャンセルしま

す。 

• Shift + F9 は、すべての実行中のノードをキャンセルし

ます。 

ノードを移動するには 

• Ctrl + Shift + 矢印は、選択したノードを矢印方向に移動

します。 

ノードのリセット 

• F8 は、選択したノードをリセットします。 

ワークフローの保存 

• Ctrl + S でワークフローを保存 

• Ctrl + Shift + S で開いているすべてのワークフローを保

存します。  

• Ctrl + Shift + W で開いているすべてのワークフローを閉

じる 

メタノード 

• Shift + F12 は、メタノードのウィザードを開きます。 

注釈を移動するには 

• Ctrl + Shift + PgUp/PgDown は、選択した注釈を重複する

注釈の前または後ろに移動します。 
 

 

Node Repository  

左下の隅には、インストールされたすべてのノードがカテゴリとサブカテゴリに整理されたノードのリポジトリがあります。KNIME 

Analytics Platformには、今までに 1500以上のノードが蓄積されています。リポジトリ内の各ノードの位置を覚えるのが大変になってきま

した。この問題を解決するために、Node Repository パネルの上部にある検索ボックスには、完全一致とあいまい一致の 2 つの検索オプシ

ョンが用意されています。 
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SAMPLE 
検索ボックス  

1.13. Node Repository パネルでの単語検索: 完

全一致モード 

 

“Node Repository”パネルの上部に検索ボックスがあります。検索ボックスにキーワード

を入力して”Enter”キーを押すと、そのキーワードに完全に一致するノードの一覧が表

示されます。”Esc”キーを押すと、再びすべてのノードが表示されます。 

 

 

検索ボックスの左側にあるレンズをクリックすると、あいまい検索アルゴリズムが実行

され、前の図で見つかったものよりも広い一致結果の一覧が表示されます。  

1.14. Node Repository パネルでの単語検索: あいまい一

致モード 

 

 

KNIME Explorer  

KNIME ワークベンチの左上には、KNIME Explorer パネルがあります。このパネルには以下が含まれています。 

- LOCAL の下に、選択したワークスペースで開発されたワークフローが表示されます。 

- マウントは、多数の KNIME サーバーを指します。  

- そのようなサーバーの参照ワークスペースに含まれるワークフローです。 

- KNIME Hub にあるMy-KNIME-Hub へのアクセスは、KNIME Hub 上のあなたのスペースへのアクセスとなります。このスペースにア

クセスするには、KNIME Forum のアカウントが必要です。 

最初、KNIME Explorer パネルには LOCAL、My-KNIME-Hub、EXAMPLES のみが表示されています。既に述べたように、LOCAL は選択したワ

ークスペースの内容を表示します。EXAMPLES は、匿名ログインでアクセスできる読み取り専用のパブリックサーバーを指します。この
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SAMPLE 
サーバーは、新しいプロジェクトを開始するために使用できるサンプルワークフローを提供しています。My-KNIME-Hub は KNIME Hub 上

のスペースにアクセスすることができます。 

初めて KNIME Analytics Platform を開くと、”Example Workflows”という名前のフォルダがあり、そこにはデータを包括するいくつかの一般

的なデータサイエンスの事例に対する解決策が含まれています。  

ワークフローを含む”KNIME Explorer”内のフォルダは、”ワークフローグループ”とも呼ばれます。 

注意.KNIME Explorer パネルはデータを操作することもできます。ワークスペースフォルダの下にフォルダを作成し、そこにパソコン上の

データファイルを入れて、”KNIME Explorer”パネルのコンテキストメニュー（右クリック）で”Refresh”を選択するだけです。 

EXAMPLES サーバー 
 

“KNIME Explorer”パネルには、KNIMEのパブリックサーバー（EXAMPLES）へのリンクが用意

されています。これは KNIME がチュートリアルやデモのために全ユーザーに提供している

サーバーです。そこでは、KNIME を使った特定のタスクの実装方法について、多くの有用

な例を見つけることができます。EXAMPLES サーバーに接続するには 

- “EXAMPLES”パネルの”EXAMPLES”をダブルクリックします。 

- “Double click to connect…”をダブルクリックします。 
 

ゲストとして自動的にログインする必要があります。 
 

EXAMPLES サーバーから LOCAL ワークスペースにサンプルワークフローを転送するには、

ドラッグ＆ドロップするか、”EXAMPLES” から “LOCAL” にコピー＆ペースト（Windows の場

合は Ctrl-C、Ctrl-V）するだけです。 
 

Workflow Editor でサンプルワークフローを開くこともできます。上部の黄色の警告ボック

スは、このワークフローコピーが保存されないことを警告しています。 

1.15. KNIME Explorer パネル。上部には EXAMPLES 

サーバーの内容、下部には LOCAL ワークスペース

の内容が表示されます。 
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SAMPLE 
KNIME Explorer パネルは、複数の KNIME サーバーをホストすることができます。利用可能な KNIME サーバーの一覧にサーバーのマウン

トポイントを追加するだけで十分です。  

KNIME Explorer でのサーバーのマウント  
 

“KNIME Explorer”パネルに KNIME サーバーを追加するには 

 

- “KNIME Explorer”パネルを選択します。 

- “Configure Explorer View”ボタンをクリックします。 

 
 

1.16. “Configure KNIME Explorer”ボタン 
 

 
 

- KNIME Explorer”ページで”Preferences (Filtered)” 画面が開き、この

KNIME インスタンスに既にマウントされている全ての KNIME スペー

スが一覧表示されます。すべての KNIME インスタンスでデフォルト

で利用可能な 3 つの KNIME スペースは、ローカルワークスペー

ス”LOCAL”、KNIME パブリックサーバー”EXAMPLES”、そして KNIME 

Hub サーバー(hub.knime.com)上にあるMy-KNIME-Hub です。 

- “New”と”Remove”ボタンを使用して、リモートサーバーへの接続を

追加/削除します。 
 

- „New”ボタンをクリックした後、”Select New Content”画面で、サーバ

ーに関する必要な情報を入力します（図 1.18）。 
 

- “Test Connection”ボタンを使用して、選択したサーバーのデフォルト

のマウントポイントを自動的に取得します。 
 

同じ KNIME Explorer の”Preferences”ページは、トップメニューの”File”→ 

“Preferences”→ “KNIME Explorer”からアクセスできます。 

1.17. „Preferences (Filtered)” 画面 

 

 

“KNIME Explorer”パネルで利用可能なサーバーにログインします。 
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SAMPLE 
- サーバ名を右クリックまたはダブルクリックします。 

- 認証情報を提供します。 

1.18. “Select New Content” 画面 

 

 

Workflow Editor  

KNIME ワークベンチの中心となるのが Workflow Editor です。ここでは、次々にノードを追加してワークフローを構築します。ノードは、

Node Repository や Workflow Coach からドラッグ＆ドロップやダブルクリックで Workflow Editor に挿入されます。ワークフロー構築のプ

ロセスについては、本書の次の章で広く解説します。ここでは、Workflow Editor のキャンバスの役割をカスタマイズし、おそらく改善す

る方法を説明します。2 つのオプションについて説明します。  

- グリッドを使ってキャンバスの外観を変更したり、接続のために異なる可視化を行うことができます。  

- 作品にコメントをつけるための注釈を導入します。  
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SAMPLE 
キャンバスにグリッドを追加し、ワークフローに曲線の接続を追加 

最後の方、ツールバーの右側に”Change Workflow Editor Settings”ボタンがあります。それをクリックすると、”Workflow Editor Settings” 画

面が開きます。  

1.19.ツールバーの”Change Workflow Editor Settings”ボタン 

 

Workflow Editor のカスタマイズ  
 

グリッド機能にはいくつかのオプションがあります。 
 

1. “Show grid lines”：これにより、Workflow Editor にグリッド線を表示

し、ノードと注釈を手動で整列させることができます。  
 

2. “Snap to grid”：このオプションは、ノードと注釈をグリッドの最も近

いコーナーにアタッチします。手作業の自由度は低くなりますが、結

果はよりすっきりとしたものになり、より短時間で整然としたものに

なります。 
 

3. “Curved Connections”：ここでは、ノードの接続を直線ではなく曲線に

沿うようにすることができます。これにより、より魅力的なワークフ

ロー・グラフィックスになるかもしれません。 

1.20. “Workflow Editor Settings” 画面 

 

 

キャンバスに注釈を追加 

Workflow Editor に注釈を含めることも可能です。注釈は、ワークフローのタスクや各ノードの機能を説明するのに役立ちます。その結果、

ワークフローの一般的なタスクと単一のサブタスクのドキュメントのような概要が改善されます。 
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SAMPLE 
ワークフローの注釈  
 

新しい注釈を挿入：  

- Workflow Editor の任意の場所を右クリックして、”New Workflow Annotation”を選択

します。 

- 淡黄色の小さな枠が表示されます。 

- 枠をダブルクリックして内容を編集します。 

1.21. アノテーションエディタ 

 

- 上部に表示されるツールバーで、テキストのスタイル、フォントの色、背景色、テキストの配置、境界線のプロパティ(色、濃

淡)を編集することができます。 

- 注釈を再度開くには、鉛筆のアイコンがある左上の角をダブルクリックするだけです。 

その他のワークベンチのカスタマイズ  

 

カスタマイズのためのもう一つの可能性は、ビューを追加することです。利用可能なビューは、

トップメニューの”View”項目にあります。   
 

人気のあるビューは、例えば、”Node Monitor”、”Custom Node Repository”、”Licenses”と”Server”

です。これらの追加のビューはすべて、トップメニューの”View” -> “Other” -> “KNIME Views”から

見つけることができます。  
 

“Node Monitor”ビューは、特に開発フェーズにおいて、ワークフローの実行を監視し、デバッグ

するのに役立ちます。  
 

“Custom Node Repository”では、ノードのサブセットのみでカスタマイズした”Node Repository”を

作成することができます。 
 

“Licenses”は、あなたが何かを持っている場合は、ライセンス状況を監視することができます。 

1.22. „View” -> „Other” ->  “KNIME Views”の

からの追加表示
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SAMPLE 
Node Monitor ビュー  
 

ワークベンチに”Node Monitor”パネルを挿入するには ： 

- トップメニューの”View”-> “Other…”を選択します。 

- “Show View” 画面で”KNIME Views”項目を展開し、”Node Monitor”をダブルクリックすると、”Console”パネルの横に”Node 

Monitor”というパネルが表示されます。  

- そこでは、右上のメニューから何を表示するか（データ、設定、変数）を決めることができます。 
1.23. Node Monitor ビュー 

 
 

1.8. KNIME 拡張機能のダウンロード  

KNIME Analytics Platform はオープンソース製品です。他のオープンソース製品と同様に、コミュニティが開発するフィードバックや機能

から恩恵を得ています。KNIME Analytics Platform には多くの拡張機能が利用可能です。すべての無料の拡張機能を含む KNIME Analytics 

Platform をダウンロードしてインストールした場合、Node Repository パネルには、KNIME Labs、Text Processing、R Integration などの対応

するカテゴリが表示されます。  

ただし、インストール時に無料の拡張機能を含まない KNIME Analytics Platform をインストールすることを選択した場合は、実行中のイン

スタンスに個別にインストールする必要があるかもしれません。 
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SAMPLE 
KNIME 拡張機能のインストール  

KNIME Analytics Platform 内から新しい KNIME 拡張機能をインス

トールするには、2 つのオプションがあります。 

1. トップメニューから”File” -> “Install KNIME Extensions”を

選択し、目的の拡張機能を選択して”Next”ボタンをクリ

ックし、ウィザードの指示に従います。 

または、 

2. トップメニューから”Help” -> “Install New Software”を選

択します。”Available Software”画面の、”Work with”テキ

ストボックスで、KNIME のアップデートサイト（通常

は ”KNIME Analytics Platform 4.x Update Site”- 

http://update.knime.com/analytics-platform/4.x）の URL を選択

します。その後、拡張機能を選択し、”Next”ボタンをク

リックし、ウィザードの指示に従います。 

選択した KNIME 拡張機能がインストールされ、KNIME が再起動

されると、”Node Repository”にインストールされた拡張機能に

対応する新しいカテゴリが表示されます。 

 

1.24. „Available Software” 画面 

 

 

“Available Software” 画面では、いくつかの拡張機能グループを見つけることができます。KNIME & Extensions, KNIME Labs Extensions, KNIME 

Node Development Tools, Sources などです。”KNIME & Extensions”には現在のリリースで提供されている全ての拡張機能が含まれていま

す。”KNIME Labs Extensions”には使用可能な拡張機能が含まれていますが、まだ x.1 のリリースの品質ではありません。”KNIME Node 

Development Tools”には Java プログラマーがノードを開発するための便利なツールが含まれています。”Sources”には KNIME のソースコー

ドが含まれています。サードパーティやコミュニティから提供された特定のパッケージも拡張機能の一覧に含まれている場合があります。

これらは通常、”Community”カテゴリの下にグループ化されています。私のアドバイスとしては、ケムインフォマティクスのものも含め
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SAMPLE 
て、すべての拡張機能をインストールすることです。それらの多くには、特定のドメインに限定されていない有用なノードがいくつか含

まれています。 

1.9. 本書のデータとワークフロー  

この本は、いくつかの例題を作成し、演習問題の解答を提供しています。これらは、本書の著者の一人である KNIME Hubのスペースから

ダウンロードできる”BeginnersLuck”というフォルダに含まれています。KNIME Hub にアクセスするには、KNIME Forum のアカウントを作

成する必要があります。KNIME Hub に入った後、ワークフローをダウンロードするには、クラウドアイコンをクリックするだけです。  

- お使いのマシンにフォルダ全体をダウンロードすると、.knar ファイルが作成されます。その後、以下のようにしてください。 

- ダブルクリックするか、ファイルを選択し、 Import KNIME Workflow …で KNIME Explorer にインポートしてください。 

1.25. KNIME Hub (https://hub.knime.com/hayasaka/spaces/Public/latest/KNIMEPress/KNIME_Beginners_Luck_4.1_20200423/)に掲載されている本書のワークフローとデータ 

 

インポート操作の最後に、KNIME Explorer パネルでは、Chapter2、Chapter3、Chapter4、Chapter5、Chapter6 のサブフォルダを含む

BeginnersLuck フォルダがあり、それぞれ次の章で実装されるワークフローと演習が含まれています。また、必要なデータを含む KBLdata

フォルダも見つかるはずです。 

https://hub.knime.com/hayasaka/spaces/Public/latest/KNIMEPress/KNIME_Beginners_Luck_4.1_20200423/
https://forum.knime.com/
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SAMPLE 
本書の演習とワークフローのデモに使用されているデータは、著者が作成したものか、公開データリポジトリである UCI Machine Learning 

Repository(http://archive.ics.uci.edu/ml/datasets)からダウンロードしたものです。データセットが UCI リポジトリに属している場合は、完

全なリンクをここでダウンロードすることができます。著者が生成したデータで、公開データではないものは、KBLData フォルダにあり

ます。  

UCI 機械学習リポジトリのデータ： 

• Adult.data：   http://archive.ics.uci.edu/ml/datasets/Adult 

• Iris data：   http://archive.ics.uci.edu/ml/datasets/Iris 

• Yellow-small.data (Balloons)：http://archive.ics.uci.edu/ml/datasets/Balloons  

• Wine data：   http://archive.ics.uci.edu/ml/datasets/Wine 

1.10. 演習  

演習 1  

自分のワークスペースを作成し、”book_workspace”という名前を付けます。このワークスペースは、次のワークフローや演習で使用しま

す。 

演習問題 1 の解答 

http://archive.ics.uci.edu/ml/datasets
http://archive.ics.uci.edu/ml/datasets/Adult
http://archive.ics.uci.edu/ml/datasets/Iris
http://archive.ics.uci.edu/ml/datasets/Balloons
http://archive.ics.uci.edu/ml/datasets/Wine
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SAMPLE 
 

• KNIME を起動します。 

• ワークスペース・ランチャー・画面で、”Browse”をクリ

ックします。 

• 新しいワークスペースのパスを選択します。 

• “OK”をクリックしてください。 

 

これをデフォルトのワークスペースとして維持するには、左

下隅のオプションを有効にします。 

1.26. 演習 1：ワークスペース”book_workspace”の作成 

 

演習 2  

以下の拡張機能をインストールします： 

- KNIME Database 

- KNIME Javascript Views 

- KNIME Report Designer  

演習問題 2 の解答 

トップメニューから”File” -> “Install KNIME Extensions”を選択します。 

必要な拡張機能を選択します。 

“Next”をクリックして指示に従います。 
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SAMPLE 
1.27 .演習２：KNIME 拡張機能の一覧 

 

1.28. 演習２：レポートの拡張機能 

 
 

演習 3  

Node Repository 内のすべての”Row Filter”ノードを検索します。 

“Node Description”パネルから、”Row Filter”、 “Reference Row Filter”、 “Nominal Value Row Filter”の違いを説明できますか？ 

以下のデータテーブルを使用して、ノードの効果を表示します： 
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SAMPLE 
主テーブル 

 
Position name team 

1 The Black Rose 4 

2 Cynthia 4 

3 Tinkerbell 4 

4 Mother 4 

5 Augusta 3 

6 The Seven Seas 3 

参照テーブル 
 

Ranking scores 

1 22 

3 14 

4 10 

  

 

演習問題 3 の解答 

Row Filter 

このノードでは、特定の条件で行をフィルタリングすることができます。特定の範囲（行番号による）、特定の行 IDを持つ行、選択可能な列（属性）

の特定の値を持つ行などを含めることも除外することもできます。以下の例では、次のようなフィルタリング基準を使用しています。 

    主テーブル 

 

 

            

 

Position name team 

1 The Black Rose 4 

2 Cynthia 4 

3 Tinkerbell 4 

4 Mother 4 

5 Augusta 3 

6 The Seven Seas 3 

フィルタリングされた主テーブル 

 Position name team 

1 The Black Rose 4 

2 Cynthia 4 

3 Tinkerbell 4 

4 Mother 4 

 

Reference Row Filter 
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SAMPLE 
このノードは 2つの入力テーブルを持っています。下のポートに接続されている 1番目の入力テーブルが参照テーブルとして使用されます。上のポートに接続されている

2 番目の入力テーブルは、フィルタリングされるテーブルです。参照テーブルの参照列と、2 番目のテーブルのフィルタリングする列を選択する必要があります。フィルタ

リングする列の値が参照列にも存在するすべての行は、”include”オプションが選択されている場合には保持され、”exclude”オプションが選択されている

場合には削除されます。 

                
 
 

上の例では、参照テーブルの参照列に”Ranking”、フィルタリングテーブルのフィルタリング列に”Position”を使用しています。共通の行を含めること

にしました。 

Nominal Value Row Filter 

Ranking scores 

1 22 

3 14 

4 10 

参照テーブル 

 

 

 

Position name team 

1 The Black Rose 4 

2 Cynthia 4 

3 Tinkerbell 4 

4 Mother 4 

5 Augusta 3 

6 The Seven Seas 3 

フィルタリングされたテーブル 

 

Position name team 

1 The Black Rose 4 

3 Tinkerbell 4 

4 Mother 4 

結果テーブル  



 

54 

 

 

SAMPLE 
カテゴリ属性の選択された値に基づいて行をフィルタリングします。カテゴリ列とこの属性の 1 つ以上のカテゴリ値をフィルタ基準として選択することがで

きます。選択された列にこれらのカテゴリ値がある行は、出力データに含まれます。基本的には、カテゴリ値を持つ列に適用される行フィルタです。カテゴ

リ列は文字列であり、カテゴリ値はその中の値です。  

以下の例では、カテゴリの列として”name”を、フィルタリングの基準として”name = Cynthia” を使用しています。 

 

    主テーブル 

 

 

            

 

Position name team 

1 The Black Rose 4 

2 Cynthia 4 

3 Tinkerbell 4 

4 Mother 4 

5 Augusta 3 

6 The Seven Seas 3 

フィルタリングされたテーブル 

 Position name team 

2 Cynthia 4 

  


